Real Estate Continuing Education
Frequently Asked Questions

I am using an old version of FireFox and cannot hear the audio.

For old versions of Firefox on Windows (version 20.0 or earlier), you must install the Windows Media Player Plugin.   Alternatively, you can just update your software to the latest version of Firefox by going to the Firefox button in the upper left, then Help->About.